Jump to content
  • Welcome!

    Welcome to the Ford SYNC Forum!  Please sign in here or create an account here.



lilarlen

Update sync 3 to latest version 3.4 (?)

Recommended Posts

My dad has a 2016 Ford Edge, he would like to update the Sync system. I am trying to help.

He has a Sync 3 system ver 3.0 build 18093.

Would like to go to latest Sync 3 version, which I think is 3.4.

Do I need to do any incremental versions before jumping up 3.4 or can I just download 3.4, place it on a thumb drive and update his Edge.

 

If this is possible,  are there some forum threads I can read about how to do this, or some youtube videos to watch or ??

 

Never done anything like this before, just trying to help my dad.

 

Thank you in advance for your help!

 

Share this post


Link to post
Share on other sites

It is not possible to just upgrade the software to go from 3.0 to 3.4

Most of the things you will see are more cosmetic, than functional.... so have them stay at 3.0

It might cost a few hundred dollars to get to 3.4, but then you would not get the automatic updates.

Yes, in the long run it can be done, but if your dad needs your help, best to just stick with what he has.  8)

Share this post


Link to post
Share on other sites
14 hours ago, lilarlen said:

My dad has a 2016 Ford Edge, he would like to update the Sync system. I am trying to help.

He has a Sync 3 system ver 3.0 build 18093.

Would like to go to latest Sync 3 version, which I think is 3.4.

Do I need to do any incremental versions before jumping up 3.4 or can I just download 3.4, place it on a thumb drive and update his Edge.

 

If this is possible,  are there some forum threads I can read about how to do this, or some youtube videos to watch or ??

 

Never done anything like this before, just trying to help my dad.

 

Thank you in advance for your help!

 

The latest available for Sync 3.0 is 3.0.20204.  Check the Ford site using the VIN to be sure it is available for the 2016, but I believe it should be.

 

There are ways to get 3.4 for that vehicle by going around Ford, but it would not be supported by Ford.  As previously mentioned, it would be best to stick with 3.0.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Custom Search

×